• Welcome to Windows10Forum.com, a free community where people just like you come together to discuss, share and learn how to use their computers. Using this forum is easy and fun. As a guest, you can browse and view all the content on the site, however, you won't be able to leave comments or create new topics unless you create a free account. 

    Click here to Register a free account now and JOIN the discussion!

Anil

Fastest way to download Windows 10 ISO

Recommended Posts

Anil    0

Hi.

I have been trying to download windows 10 iso. The size of the current iso file is approximately 4GB. Download methods, i tried:

  1. Media Creation Tool
  2. Upgrade Assistant
  3. Direct Link (24 hour expiration)

The problem is the download speed. I have 1mbps connection, so the download time is above 10/12 hours. 

But, the speed is different while downloading windows 8.1, today i tried to download windows 8.1 (media creation tool), the waiting/downloading time is less than a hour. So, i did little research, then i found that the media creation tool was downloading the 8.1 iso file through a CDN ( akamai ), the connection speed was 19/24 mbps. So here is my question : how can i download windows 10 iso with this faster speed?

 

Thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • By kai
      I've been having some issues lately with the computer freezing when I try to log into Chrome. Chrome woukd take hours to load and when it finally did, Chrome did so with an error about user preferences not being able to be read and there was an error with my user profile. 
      Now, I can't even boot my computer up. I just get a black screen afyer the HP logo and if happens when i rry to boot safe mode with nstworking, too. Please help. I'm late to send out a proposal as it is.
    • By Amahanako
      For the past week or so, my laptop will not startup. It will not load anything at all; no Toshiba logo, no Windows screen, nothing, ie I CANNOT get into safe mode at all. Instead the screen stays black and a light will flicker on and off. Power light, WiFi light, and battery light all light up normally.
      Sometimes, it will eventually boot up and I can use it without any problems. 
      I am running Windows 10 on a Toshiba satellite c55-c5241.
      Any help would be appreciated!
    • By Marya
      I just got a new laptop with windows 10 installed. I would like to change the tiles on the desktop to icons. I have no idea how to do this. Help!
    • By Jillian
      Okay, I'll just run down what went down before the problem arose.
      I am running Windows 10 with the Creators Update and I ran into a weird problem. This morning, when I was booting up my laptop (it's an ASUS X556UF) and I came across what looks like a black screen with the loading circle (the white spinning dots) and at first I thought it was just normal until after an hour and I knew something was up. The cursor is visible and when I pressed ENTER and hovered my mouse in some places I noticed it was detecting a text field (which is the password input for the user login). So I blindly typed in my password (the screen was still showing the loading black screen) and it was sucessful. I was in my desktop but all I can see is the black screen with the spinning dots. Now, the way I confirmed that the desktop loaded was I double-clicked on the area where I had some music files and hey, it actually played with audio. (Did the same with some games I had and the game loaded although the screen didn't change). When all this was happening, none of the explorer.exe elements showed up ( CTRL+ALT+DEL doesn't even show anything but it's there since the cursor can detect the options by turning into the hand with the pointer finger sticking out). 
      Thankfully, I can access Safe boot (by using the power button of my laptop to put the laptop in the WinRE) but I still can't pinpoint the culprit. I've spent all day tracing back all the changes I made when it was still operational but to no avail. 
      Tried uninstalling and reinstalling the Graphics Driver (NVIDIA 930M), ran SFC and the file integrity wasn't compromised, tried disabling non-Windows services on startup through msconfig, and I can't even do a Reset since it always says "There was a problem resetting your PC. No changes were made."
      Any help would be appreciated, being stuck in Safe boot for all eternity is not how I want to go with using my laptop from now on.
    • By Norwen
      It keeps repeating,  this is the  fourth time already from 100% it goes back to 0%
      Is this normal or it means it has a problem? 

  • Who's Online   0 Members, 0 Anonymous, 17 Guests (See full list)

    There are no registered users currently online