Jump to content
  • Windows 10 Forums

    Welcome to the Windows 10 forums, a free community where people just like you come together to discuss, share and learn how to use their computers.

    As a guest, you can browse and view all the content on the site, however, you won't be able to leave comments or create new topics unless you create a free account. 

num lk key light won't shut off


Helixal

Recommended Posts

I recently upgraded to win 10.  After I updated the video driver the numbers lock/scroll key light on my laptop became lit.  The laptop noes not have a numeric keypad.  I edited the registry entry for control panel/keyboard/i initial state under current user, default user, and three others.  Changed the parameter from 2 ( on) to 0 (off).  After reboot the current user setting reverts to 2 and the light remains on.  Any suggestion for turning off the light?

Link to comment
Share on other sites

Hi @Helixal If you've been in the registry,  you probably know what you're doing and my questions may sound dumb.

You said you updated the graphics driver? Can you not roll back the driver?? Do you have a restore point before your problem? Did you go to your manufacture to get the latest graphics driver. Also if you post your make and model, another member might better help you with the driver.

Welcome to the forum!

If all else fails! Have you thought about a in place- repair upgrade as a last result?

http://www.tenforums.com/tutorials/16397-repair-install-windows-10-place-upgrade.html

Here's a good read about drivers by HTG. 

http://www.howtogeek.com/98465/htg-explains-when-do-you-need-to-update-your-drivers/

Link to comment
Share on other sites

holdum333-

 

Thanks for the reply.  I did do a rollback- no change.  Actually I found that I had not upgraded the driver.  The driver was the one that windows 10 loaded.  So I went to AMD and got the latest driver for my machine.  Still the light stays on.  It's puzzling that that the registry value is getting reset to a 2 value after I change it to a 0. Everyone has told me that the video driver has nothing to do with num ok light.  

Link to comment
Share on other sites

32 minutes ago, Helixal said:

So I went to AMD and got the latest driver for my machine.

1 - I'm sure you already did this but, have you flashed the BIOS on the machine before or after the update to Windows 10? I ran into a lot of issues on my Lenovo until I did this. 

2 - Next question - do you have any Virtual Machines on this laptop? This could also be impacting your HOST laptop ie: Do Guest VM's have Num Lock enabled? 

3 - Check your BIOS. Sometimes Num Lock and Caps Lock settings can be configured in your BIOS settings on the laptop. 

4 - Here's some additional data re: Num Lock and Caps Lock Lock Keys

To enable NUM LOCK before a user logs on, follow these steps:

  1. Run Registry Editor.
  2. Move to:
    HKEY_USERS\.Default\Control Panel\Keyboard
  3. Change the value for InitialKeyboardIndicators using setting below:

 

0 – Turn all indicators Off (Numlock, CapsLock, ScrollLock)
1 – Turn CapsLock On
2 – Turn Numlock On
3 – Turn CapsLock and Numlock On
4 – Turn ScrollLock On
5 – Turn CapsLock and ScrollLock On
6 – Turn Numlock and ScrollLock On
7 – Turn all indicators On (Numlock, CapsLock, ScrollLock)

Link to comment
Share on other sites

Heya @Rich-M Don't know the make and model of the PC the poster is running. I had this posted earlier, but it got deleted.

May not work but, but i will post it anyway!:ph34r:

 

Press 2 keys at the same time: "FN" (next to the CTRL key, lower-left of the keyboard) and "num lk", which is the upper-right of the keyboard (it is on the same key as "scroll", and is next to "F12").

This will either turn on or turn off the "Num Lock" function. Both the "FN" and "num lk" are enclosed in a small rectangle.
 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Who's Online   0 Members, 0 Anonymous, 1 Guest (See full list)

    • There are no registered users currently online
×
×
  • Create New...