Jump to content
  • Windows 10 Forums

    Welcome to the Windows 10 forums, a free community where people just like you come together to discuss, share and learn how to use their computers.

    As a guest, you can browse and view all the content on the site, however, you won't be able to leave comments or create new topics unless you create a free account. 

Deleteing File - Access is denied

Maybe Morpheus

Recommended Posts


I have a problem that I was wondering could be caused by malware:

So I have a file in my google drive folder in windows 10. I deleted it once (using Shift+Del to permanently delete), but it promptly reappeared, and now when I try to delete (using normal deleting) it, a dialogue box pops up saying that "Access is denied" and that admin permission is required. If I click continue, the box text changes but still doesn't allow me to delete it, which is odd considering I am the admin.

If I right click on it and go to properties, then the security tab says "you must have read permissions to view the properties of this object". Any path that I try doesn't allow me to delete it.

I imagine that if I booted into safe mode I could delete the file, but as this has happened before I'm sure it will happen again, so what I'm really trying to do is to find the root cause of the problem so it doesn't happen again. Maybe it is caused by google drive?

In case this is of any note, I have MacAfee installed.

Thanks in advance for your help,





Link to comment
Share on other sites

  • 2 weeks later...

Looks like a game or something you grabbed. It's a Python script file. 

One thing you can try is going to your Google Drive via Web Browser (Goto Gmail, App Changer to Drive) and delete the entire folder Tree. It looks like it's in your Programming\python folder. If you didn't create that folder tree, blow it all away.

If you delete it via your browser, it should also sync and delete from your PC also. Otherwise, you will need to take ownership of the file/folder to get access to nuke it.

Either way - yeah, suspicious.

Link to comment
Share on other sites

I knew it was a python script - I created it (it's not a game, it's a sudoku solver, hence the name :) )

Either way, the file has now mysteriously disappeared even though I haven't touched it since leaving this post - if I go into the "Trash" section of google drive online it shows the last modified date as 23 September 17, which is the day after I tried to delete it...

Part of my efforts to delete it included trying to take ownership, which seemed impossible - I didn't have permission to take ownership...

Link to comment
Share on other sites

On 10/1/2017 at 8:13 AM, Maybe Morpheus said:

I knew it was a python script

Um... Right... ;)

On 10/1/2017 at 8:13 AM, Maybe Morpheus said:

Either way, the file has now mysteriously disappeared

So my guess -- Google Drive was doing something screwy with your file system and just needed time to catch up from the sync... 

Glad it's all working again. (unless it's still having issues with other files...).

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Who's Online   0 Members, 0 Anonymous, 9 Guests (See full list)

    • There are no registered users currently online
  • Create New...