Jump to content
  • Windows 10 Forums

    Welcome to the Windows 10 forums, a free community where people just like you come together to discuss, share and learn how to use their computers.

    As a guest, you can browse and view all the content on the site, however, you won't be able to leave comments or create new topics unless you create a free account. 

iAqualink Message Error

Tom M

Recommended Posts

My iAqualink pool controller recently quit working when I changed wifi routers.  Originally, it appeared that I just needed to update the software for the controller to fix that problem.  However, when I did that, I got a runtime error "67" (too many files).  When I contacted iAqualink support, they indicated there was no fix for this error, and I essentially needed to buy a $300 update kit. Not wanting to spend that much money if I didn't have to, I googled for the error code and found the info below:

Visual Basic for Applications Reference

Visual Studio 6.0
Too many files (Error 67)


There is a limit to the number of disk files that can be open at one time. This error has the following causes and solutions:

  • MS-DOS operating system: More files have been created in the root directory than the operating system permits.

    The MS-DOS operating system limits the number of files that can be in the root directory, usually 512. If your program is opening, closing, or saving files in the root directory, change your program so that it uses a subdirectory.

  • MS-DOS operating system: More files have been opened than the number specified in the files= setting in your CONFIG.SYS file.

    Increase the number specified in the files= setting in your CONFIG.SYS file and restart your computer.

I tried to find the CONFIG.SYS file to no avail.  After doing a little more digging, I came to the conclusion that Windows 10 might not have the MS-DOS operating system that previous Windows versions used.  If anyone could tell me if there is a Windows 10 equivalent to the files = setting in the CONFIG.SYS file, I would like to try to make that change and see if it would solve the problem.  Much appreciated!

  • Upvote 1
Link to comment
Share on other sites

Sorry, when I saw you had responded, I was hoping you had found a way around it.  I originally got an Error 52 - Too many files.  When I ran the wifi tool, it changed to Error 67 - Too many files.  The tech at iAqualink told me that they had fixed the error 52 issue, but not the error 67.  He said the only way to get the iaqualink to connect to the my wifi signal is to get a $300 upgrade kit that has a new antenna.  Since I paid over $500 for a completely new iaqualink four years ago, I'm not thrilled to have to pay an additional $300 to upgrade, especially when I suspect there is a software issue they could fix but have elected not to.  BTW, my iaqualink was connecting just fine until changed internet services and got a new router.  I will do a followup post if I come up with a solution that does not require buying the upgrade kit.

  • Upvote 1
Link to comment
Share on other sites

  • 2 years later...

I started with the 52 error. On another forum thread I saw to connect to the iaqualink drive and repair. When I ran the configuration program again got the 67 error. Looked at the drive and saw that it had no files were before it had a SETTINGS file. I turned on show hidden files in windows and saw several files from 2011 when I bought the iaqualink and one ._SETTINGS file from 2017. There was very little space on the iaualink flash drive so I deleted the SETTINGS file. Re-ran the Configuration program and it completed successfully.

Link to comment
Share on other sites

  • 3 years later...

I'm sorry to hear that you're experiencing an error with your iAqualink message. Can you please provide more information about the error message you're receiving? This will help me provide you with a more accurate solution.

In the meantime, you can try restarting your iAqualink system or resetting it to its factory settings to see if this resolves the issue. You may also want to ensure that your device is connected to a strong and stable internet connection, as connectivity issues can often cause error messages.

If the issue persists, please provide me with more details about the error message, and I will do my best to assist you further.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Who's Online   0 Members, 0 Anonymous, 5 Guests (See full list)

    • There are no registered users currently online
  • Create New...