Jump to content
  • Windows 10 Forums

    Welcome to the Windows 10 forums, a free community where people just like you come together to discuss, share and learn how to use their computers.

    As a guest, you can browse and view all the content on the site, however, you won't be able to leave comments or create new topics unless you create a free account. 

A VR Headset problem.

Recommended Posts

Many appologies if in the wrong department, but a search found nothing suitable.

I have an HP Reverb G2. It was working fine for about 4 months. Then I stopped getting power to the headset (although the power light was on the connector block). A long chat with HP Support and trying a number of checks and fixes, they then decided to replace the headset (8 months left on the guarantee). When it arrived (jolly quick I might add), I eagerly plugged it in, got the 'Activity' light on the front to illuminate and after a min I could feel it getting warm. BUT. Every time I run the WMR Portal, I get a mixture of 3 different messages:- "Getting things ready" (looping) / "The headset is sleeping - WAKE UP" / "Input is currently being directed to the Desktop and not the Head Mounted Display. Press Win+Y to swith it back". Trying to click the WAKEUP button does nothing. Pressing Win+Y does nothing. Another chat with HP and another run through the usual checks and fixes achieves nothing (Getting expensive these phone calls!), so this time they are going to send me an uprated cable - when they get some back in stock. Personally I have my doubts that this will fix the problem, so while I am waiting (and still trying anything that I can think of) I thought I would put out some feelers and see if I get any luck from a very knowledgeable person out there somewhere. At the moment tho' I am sitting here looking at a very expensive paperweight (£649.00 UK!! Daughter says that I am completely bonkers.). It seems to me that either the PC or Windows or Graphics Card is somehow stopping any video signal from being sent to the head display. I find it hard to believe that a cable connection could just suddenly break(?).


i5 9600K OC'd to 4.8 GHz / 32 GB Corsair Vengeance RAM / RTX 3080 Ti (Yep, I paid through the nose for that as well!) / RM850 (Gold) PSU. Everything software wise is updated, inc Winwows 10 Pro. Interestingly, the 'Perception Simulation Headset' driver (Device Manager) is dated 2006 - 15 years old! - but it informs me that I have the latest drivers!?

Link to comment
Share on other sites

2 days later and still no-one bytes (sorry, I mean bites LOL). Well, the 'improved' cable was delivered this morning. I do now occasionally get a picture on the HMD but it usually only lasts a few seconds before disconnecting again - while at the same time dislplaying "Input is currently being directed to the Desktop and not the Head Mounted Display. Press Win+Y to switch back" - pressing Win+Y does not help. Tracking seems to be working OK tho, as movement of the headset is mirrored in the WMR desktop screen, yet without anything displaying in the headset. Audio is being piped through the headset speakers correctly. I have tried using the USB 'C' socket and 2 USB 'A' sockets using the supplied adapter. It is currently plugged into a USB 'A' socket marked 'VR Ready' (which makes no difference). There are 3 DP slots on the 3080 Ti and I have tried them all.

Google searches have not found anything relevant.

I guess this all means that I am now on my own and stuck with a very very expensive paperweight. Probably can't even sell it - as soon as buyer asks what's the reason for selling, I will say cos it don't work, and therefore no sale.

Thanks to everyone for your help. I am now going to go and drown myself in tears. Stupid computers, sent by the devil to drive us insane...

Edited by GlennAir1953
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Who's Online   0 Members, 0 Anonymous, 7 Guests (See full list)

    • There are no registered users currently online
  • Create New...