Jump to content
  • Windows 10 Forums

    Welcome to the Windows 10 forums, a free community where people just like you come together to discuss, share and learn how to use their computers.

    As a guest, you can browse and view all the content on the site, however, you won't be able to leave comments or create new topics unless you create a free account. 

Blank, Light-Blue Screen after Update Reboot


Recommended Posts

Forgive me, but the description of this issue may be a bit lengthy. I've been working on it for over a week, but I'll try to boil it down to the essentials. Also, I couldn't determine with any certainty if this belongs in another section, so if a Mod believes it would be more appropriate to move it, I won't be offended. 001.png

The issue I've been having is that whenever some feature of Windows prompts a restart into some special environment, I'm greeted with the Windows logo and a message saying "Please Wait" with no spinning dots. It stays there for over a minute, with no disk activity, and then a blank, light-blue screen appears...

Then, after two or three hours, the system shuts down.

I first noticed it when I tried to use several of the features in the built-in Advanced Recovery Menu. It happened whenever I tried to launch a Command Prompt or perform a System Reset from WRE. I didn't really consider it a pressing issue because all of the options work fine if I launch them from an installation media.

But then it came to pass that enough other issues came up that I needed to do a repair install (in-place upgrade), which I've had much success with in the past. Everything went fine until the reboot stage and then the same thing happened. Windows logo, followed by a blank blue screen.

I work in a lot of different disciplines and have over 100 programs installed, so I was desperately trying to avoid having to start from scratch again, but I finally got fed up and performed a clean install. Everything went great. Windows boots up fine. But I still got the same result whenever I tried to perform the functions I just described. Except now the light-blue screen was showing an error message...

0xC1900101 - 0x20017
The installation failed in the SAFE_OS phase with an error during BOOT operation.

Some research told me that this has something to do with the actual boot process. Possibly device issues (I had unplugged everything but keyboard, mouse, and monitor long ago).

In the course of trying fixes, I saw that a bootable disk I had in my DVD drive throughout most of this period was trying to load after a reboot. That had never happened before. So I checked my BIOS, and sure enough, the DVD drive was set as the first item in the boot order. Apparently, I changed it so I could boot up my Macrium Reflect disk and reload backups when I was troubleshooting.

I moved my SSD to the first position and, Whala!! , all of the issues with my clean installation went away. So, naturally, I thought there's no reason I shouldn't load my last full backup with the new BIOS adjustment and everything would be peachy again. But no love.

And now, after much more research and testing, I strongly believe this issue is connected with how the BCD or BCD Store are configured. All my drives (5 of them) are configured as GPT, so I've been working with BCDEdit, BCDBoot, and MountVol in an effort to correct them. I'm not an expert in this area and don't really know how to spot problems.

So, I'm hoping people in this community could take a look at my config output and let me know if there are any glaring errors. I suspect that some entry is pointing to somewhere it shouldn't.

The drive config...
(this would actually be HardDrive4, since MiniTool Partition Wizard numbers them starting at 1 instead of zero)

and the code...

PS C:\WINDOWS\system32> bcdedit /enum all

Firmware Boot Manager
identifier              {fwbootmgr}
displayorder            {bootmgr}
timeout                 2

Windows Boot Manager
identifier              {bootmgr}
device                  partition=\Device\HarddiskVolume2
path                    \EFI\MICROSOFT\BOOT\BOOTMGFW.EFI
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
default                 {current}
resumeobject            {13ed97cc-662d-11e8-8d0d-4ccc6a0e3428}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 10

Firmware Application (101fffff)
identifier              {13e64c1b-e22a-11e8-8d84-806e6f6e6963}
description             UEFI: HL-DT-ST BD-RE  WH14NS40

Windows Boot Loader
identifier              {current}
device                  partition=C:
path                    \WINDOWS\system32\winload.efi
description             Windows 10
locale                  en-US
inherit                 {bootloadersettings}
recoverysequence        {cea49adf-6993-11e8-8bde-f25363603188}
displaymessageoverride  CommandPrompt
recoveryenabled         Yes
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \WINDOWS
resumeobject            {13ed97cc-662d-11e8-8d0d-4ccc6a0e3428}
nx                      OptIn
bootmenupolicy          Standard

Windows Boot Loader
identifier              {cea49adf-6993-11e8-8bde-f25363603188}
device                  ramdisk=[\Device\HarddiskVolume5]\Recovery\WindowsRE\Winre.wim,{cea49ae0-6993-11e8-8bde-f25363603188}
path                    \windows\system32\winload.efi
description             Windows Recovery Environment
locale                  en-US
inherit                 {bootloadersettings}
displaymessage          Recovery
osdevice                ramdisk=[\Device\HarddiskVolume5]\Recovery\WindowsRE\Winre.wim,{cea49ae0-6993-11e8-8bde-f25363603188}
systemroot              \windows
nx                      OptIn
bootmenupolicy          Standard
winpe                   Yes

Resume from Hibernate
identifier              {13ed97cc-662d-11e8-8d0d-4ccc6a0e3428}
device                  partition=C:
path                    \WINDOWS\system32\winresume.efi
description             Windows Resume Application
locale                  en-US
inherit                 {resumeloadersettings}
recoverysequence        {cea49adf-6993-11e8-8bde-f25363603188}
recoveryenabled         Yes
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
filedevice              partition=C:
filepath                \hiberfil.sys
bootmenupolicy          Standard
debugoptionenabled      No

Windows Memory Tester
identifier              {memdiag}
device                  partition=\Device\HarddiskVolume2
path                    \EFI\Microsoft\Boot\memtest.efi
description             Windows Memory Diagnostic
locale                  en-US
inherit                 {globalsettings}
badmemoryaccess         Yes

EMS Settings
identifier              {emssettings}
bootems                 No

Debugger Settings
identifier              {dbgsettings}
debugtype               Local

RAM Defects
identifier              {badmemory}

Global Settings
identifier              {globalsettings}
inherit                 {dbgsettings}

Boot Loader Settings
identifier              {bootloadersettings}
inherit                 {globalsettings}

Hypervisor Settings
identifier              {hypervisorsettings}
hypervisordebugtype     Serial
hypervisordebugport     1
hypervisorbaudrate      115200

Resume Loader Settings
identifier              {resumeloadersettings}
inherit                 {globalsettings}

Setup Ramdisk Options
identifier              {ramdiskoptions}
description             Macrium Reflect System Recovery
ramdisksdidevice        partition=C:
ramdisksdipath          \boot\Macrium\boot.sdi

Device options
identifier              {cea49ae0-6993-11e8-8bde-f25363603188}
description             Windows Recovery
ramdisksdidevice        partition=\Device\HarddiskVolume5
ramdisksdipath          \Recovery\WindowsRE\boot.sdi
PS C:\WINDOWS\system32>


PS C:\WINDOWS\system32> mountvolCreates, deletes, or lists a volume mount point.
Possible values for VolumeName along with current mount points are:
\\?\Volume{93ba7901-0e77-4ada-8771-cc53d6336748}\*** NO MOUNT POINTS ***
\\?\Volume{094d16b4-789f-46bc-a6bb-241cd980af2c}\*** NO MOUNT POINTS ***
PS C:\WINDOWS\system32>

The C: drive is connected to a built-in M.2 slot on the Motherboard, so it can't be moved. And the E: drive is a virtual device that I've been using since long before these issues started. The rest are all SATA. I did have a boot option set up so I could choose to launch Macrium Reflect on startup, optionally installed by their software, but I reinstalled it without that option during debugging attempts.

If you got this far, I salute you, and thanks in advance for any effort put forth.

Link to comment
Share on other sites

Well, after another 10 hours of research and failed fixes, I finally figured it out.

I had 4 hard drives and an SSD that my image was booting from, all configured as GPT, so I had my BIOS configured as UEFI only. I didn't have secure boot enabled, so I thought this couldn't be a problem. But just as a last ditch experiment, I switched it to Legacy + UEFI and BOOM! That solved all my problems. Everything in the WRE worked and I was able to complete the repair install. I can keep it in exclusive UEFI mode for normal use, but if I need to perform any actions where windows has to boot into WinPE, I have to open it up to Legacy as well.

I know having my BIOS set to UEFI exclusive didn't produce these symptoms a year ago, but I was reading another thread where the OP was describing the same problems, which he said started after he installed the Creators update. Which I'm guessing was when my issues started as well. He found a solution that involved doing a clean install from a pre-CU installation media just so that the standard 4 partitions would be created and configured: The Recovery, the EFI System, that mysterious third data one, and the Primary. Then he just restored his primary from a recent backup and that apparently fixed it for him.

So, if anyone else finds themselves in the same boat, here's a couple things you can try.

Link to comment
Share on other sites

  • 4 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...