• Welcome to Windows10Forum.com, a free community where people just like you come together to discuss, share and learn how to use their computers. Using this forum is easy and fun. As a guest, you can browse and view all the content on the site, however, you won't be able to leave comments or create new topics unless you create a free account. 

    Click here to Register a free account now and JOIN the discussion!

RandySea

Bizarre boot failure on Dell XPS 13. Tech advice needed!

Recommended Posts

Let me say first I am pretty experienced and have tried various diagnostics before posting. I have never seen this combination of seeming contradictory diagnostics while getting no error messages.

My wife’s Dell XPS 13 laptop with Windows 10 Home stopped booting after Dell Support Assistant pushed a bios and drivers update last week. After accepting the updates, there was a period of downloading, a bunch of “done” boxes, and a prompt to finish and restart.

My wife hit restart and the laptop seemed to be running normally. She doesn’t remember if she had to log on again or not. At this point, I did a full disk image backup. (Question whether I backed up the new but not yet apparent problem or not.) Then I closed the lid, which normally puts the laptop in Sleep mode. When she opened the lid, the power light came on but the screen was blank. No error messages at all. No “boot failure”, etc. I used the power switch to force shutdown then to start up again. Nothing happened.

All startup and shutdown has to be done by the power switch. Sometimes on startup there is a Dell logo, a circle of stars, and then a blank screen. Other times just a blank screen. There is never a Dell logo on opening the lid, though the power light usually comes back on. There are no error messages on starting up.

If I get the Dell logo on starting with the power switch, I can use F2 for bios info. Bios version 1.6.1, though I don’t know if that is pre or post update. The F2 bios information shows the correct hard drive info, but that may just be stored and not a rescan. I don’t know. Bootrec /scanos says there are no Windows installations.

I can sometimes use F12 for diagnostics. I can also get into Advanced Recovery Options by holding the power button for 20+ seconds, again only sometimes.

All the Dell hardware diagnostics say “passed.” Dell’s Startup Repair says there is an error, but “Startup Repair couldn’t repair your PC. “ I can boot from a USB containing Windows PE. This is a recovery USB created by Macrium Reflect, a backup program. However, it does not see any hard drive at all.

From the Advanced Recovery Options screen (20+ second hold down of the power switch), I can get to a administrator command prompt after entering my Windows password. There I can see my two main partitions plus three hidden Dell partitions. A DIR shows all my Windows and program files on C: and all my data files on the fourth partition, which shows in this window as E: but in Windows as D:. I can do file operations, like copy a file from the hard drive to a USB stick.

QUESTIONS: Does anyone have an idea what might be happening? Would some utility to fix the boot sector work without doing further and irreparable damage?

Anomalies:

1. Boot from Win PE USB stick sees no hard drive at all. Command prompt from Advanced Recovery asks for my Windows password and sees all five partitions ordered C,D,E,F,G, where E is what Windows shows as D:/

2. Sometimes after a power switch forced shutdown, the machine will come back on when the lid is later reopened. Makes me wonder if there is some unintended move into a hibernate state. I disabled hibernate right when my wife got the laptop 15 months ago. That also made me wonder if the machine got stuck somewhere while restarting itself after the bios/drivers update. That is, maybe it didn’t actually restart on pressing the restart box, but just returned to a regular running state without actually updating. Then closing the lid actually started the updates installing, and hung the machine.

Incidentally, I have talked to several Dell support people who were not helpful. All they could say was “needs a new motherboard.” Since the laptop came from Costco, their tech people also support it. Their idea was a factory re-image of the hard drive. I have to think there is a simpler solution that will not cause all the work of re-setting up programs and data. Also, it may be a bios corruption from an update, which disk re-imaging would not fix.



----------------------------------------------------------------------
Here are my notes of things tried. I did this yesterday and repeated it today while taking better notes. I have summarized the highlights above.

F2 for bios info

Boot: UEFI THNSNS512GPUK BVNe Toshiba 512Gb Par

SATA config - Raid On checked. Not checked: AHCI
Drives: SATA-2 and M.2 PICe SSD-0 both checked

Secure boot: was enabled, I disabled it for testing

No events in logs except on and off

F12 after exiting F2 screens (this is a character only screen)

Boot mode is set to: UEFI; Secure Boot: OFF

Device config: Physical disk info
Port: 1.0
Model THNSNS512GPUK NVMe Toshiba 512GB
Status Non-RAID

Diagnostics:
ePSA Pre-boot System Assessment (4304.07)
“No problems detected with this system”
Did not do extended memory tests - 38 minutes
Exit diagnostics and restart: just blank screen

Force shutdown with power button, then restart gets Dell and back to F12
Try Windows boot manager choice
Get Dell logo, circle of dots, then just blank screen
Force shutdown with power button. Restart first gets blank screen, then force shutdown and restart again gets Dell logo.

F12 and boot to USB Macrium Reflect
Browse “this PC” only shows the Recovery drives created by the USB boot, not any actual disk partitions
Search drives for Windows operating systems shows none
Exit gets Dell logo, circle of dots, then blank screen

Hold power button 30 seconds
Get Dell logo and “Please wait”, then blue Recovery
Select Advanced Recovery Options
Troubleshoot, then Advance options
Command Prompt
Choose account to continue
Logon to my account; enter password
Window titled: Administrator: X:\Windows\system32\cmd.exe
In cmd box, “not enough memory resources are available to process this command”
Change to C:
Dir looks normal for C: partition.
Change to D: It has no files, 489 Gb free. Says “Recovery.txt”
Change to E: Looks correct for D: partition folders. Just one file showing. Not sure if there were individual files in D: root. 199 Gb free.
CD Data folder; looks correct, with subfolders and individual files
Change to F: recovery
Volume is WINRETOOLS; 456 Gb free

Startup Repair
Startup Repair couldn’t repair your PC.



Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Who's Online   0 Members, 0 Anonymous, 7 Guests (See full list)

    There are no registered users currently online