• Welcome to Windows10Forum.com, a free community where people just like you come together to discuss, share and learn how to use their computers. Using this forum is easy and fun. As a guest, you can browse and view all the content on the site, however, you won't be able to leave comments or create new topics unless you create a free account. 

    Click here to Register a free account now and JOIN the discussion!

IrvS

Get-SmbConnection, W10 Home V1803, no data?

Recommended Posts

I am pretty sure it worked on the earlier update but not now?

I do have SMB1 Client enabled.

I opened an ADMINISTRATOR COMMAND PROMPT and started POWERSHELL and issued these commands:

==================

C:\WINDOWS\system32>powershell
Windows PowerShell
Copyright (C) Microsoft Corporation. All rights reserved.

PS C:\WINDOWS\system32> get-smbconnection
PS C:\WINDOWS\system32> net view
Server Name            Remark

--------------------------------------------------------------------------
\\IRV8700              Irv's 8700
\\LARAINE-XPS8500      Laraine's XPS8500
\\READYSHARE           readyshare
The command completed successfully.

PS C:\WINDOWS\system32> get-smbclientconfiguration


ConnectionCountPerRssNetworkInterface : 4
DirectoryCacheEntriesMax              : 16
DirectoryCacheEntrySizeMax            : 65536
DirectoryCacheLifetime                : 10
DormantFileLimit                      : 1023
EnableBandwidthThrottling             : True
EnableByteRangeLockingOnReadOnlyFiles : True
EnableInsecureGuestLogons             : True
EnableLargeMtu                        : True
EnableLoadBalanceScaleOut             : True
EnableMultiChannel                    : True
EnableSecuritySignature               : True
ExtendedSessionTimeout                : 1000
FileInfoCacheEntriesMax               : 64
FileInfoCacheLifetime                 : 10
FileNotFoundCacheEntriesMax           : 128
FileNotFoundCacheLifetime             : 5
KeepConn                              : 600
MaxCmds                               : 50
MaximumConnectionCountPerServer       : 32
OplocksDisabled                       : False
RequireSecuritySignature              : False
SessionTimeout                        : 60
UseOpportunisticLocking               : True
WindowSizeThreshold                   : 8

=================

Why no output from Get-SmbConnection?

 

 

Share this post


Link to post
Share on other sites

Never mind, got it working. Had to make the router share an attached drive:

 

=======================


C:\WINDOWS\system32>net view
Server Name            Remark

-------------------------------------------------------------------------------
\\I8700              I 8700
\\READYSHARE           readyshare
The command completed successfully.


C:\WINDOWS\system32>net view \\readyshare
Shared resources at \\readyshare

readyshare

Share name       Type  Used as  Comment

-------------------------------------------------------------------------------
USB_2.0_Storage  Disk           read:admin;write:admin
The command completed successfully.


C:\WINDOWS\system32>net use z: \\readyshare\usb_2.0_storage
The command completed successfully.


C:\WINDOWS\system32>powershell
Windows PowerShell
Copyright (C) Microsoft Corporation. All rights reserved.

PS C:\WINDOWS\system32> get-smbconnection -servername readyshare

ServerName ShareName       UserName      Credential                           Dialect NumOpens
---------- ---------       --------      ----------                           ------- --------
readyshare usb_2.0_storage I8700\isp MicrosoftAccount\is@csss.com 3.1.1   1

===============================

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Who's Online   0 Members, 0 Anonymous, 22 Guests (See full list)

    There are no registered users currently online