• Welcome to Windows10Forum.com, a free community where people just like you come together to discuss, share and learn how to use their computers. Using this forum is easy and fun. As a guest, you can browse and view all the content on the site, however, you won't be able to leave comments or create new topics unless you create a free account. 

    Click here to Register a free account now and JOIN the discussion!

holdum333

Devices and Printers Menu takes forever to load

Recommended Posts

Heya friends! I couldn't agree more about MS staying the hell away from updating my drivers. They have bricked PCs in the past and  they still keep trying to mess with drivers. My thinking is that MS will never learn because they have brain dead techs working for them.:ph34r: One good thing about all this is I'm learning new things and making new friends. Thanks @gus and @ACE . You are appreciated. Devices and Printers is still loading normally at the moment!;)

9 minutes ago, ACE said:

I am thinking the same,Gus.

Why M$ thought they could do a better job of installing Drivers than us amazes me.

They should have stayed the hell away from Drivers.

Mick.

 

Share this post


Link to post
Share on other sites

Heya @ace! Sorry been busy! Here you go friend! I'm thinking this is a hopeless case. I'm now pretty sure it's not the driver. I really don't have a clue. I have reinstalled the printer several times. I just don't know what it could be. I'm thinking MS bug at the moment!;)

The printer is 4 or 5 years old. It's working fine. The only problem is it's slow loading Device and Printer. That's really not a big deal. It's just aggravating that I can't solve this. Thanks for your help. You are appreciated! Please don't spend any more of your time on this unless you are just curious like myself. I hate giving up and it looks like you do also!;) Here's what I'm running on my Toshiba lap top!

Capture28.JPG

Capture29.JPG

Edited by holdum333

Share this post


Link to post
Share on other sites

True I don't like giving up. When you uninstall the old Driver I would go a step further and use a search with program "Everything" and delete every entry in the registry. Then I would install the new drivers, not before.

Mick

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi ! @ACE I can do that. It's working normal at the moment. Next time it messes up, I'll give your suggestion a go! Thank you! Your are appreciated! It works for awhile and then it goes back to the 3 minute delay. It's very strange and it's a challenge, and I don't know what could be causing this issue. If you Google the problem, you will find a lot of unhappy users with this problem!;) I just did a reinstall with the MCT flash and Macrium Reflect a couple of days ago. That's a lot of work just for this issue. Not ready for that at the moment!:D WOW there are 3 thousand + entries in "search"

21 minutes ago, ACE said:

True I don't like giving up. When you uninstall the old Driver I would go a step further and use a search with program "Everything" and delete every entry in the registry. Then I would install the new drivers, not before.

Mick

 

Capture28.JPG

Edited by holdum333

Share this post


Link to post
Share on other sites

Hi fiends! To all those that are watching this thread, here's a update. Some times Devices and Printers opens normally. The next time it takes 3+ minutes.

I have tried every thing possible to fix this issue, but it still persists. Here's my latest discovery. Devise manager is saying my HP printer does not have a driver.

That is total BS. It has a driver and my printer works just fine. This issue has finally exhausted all my patience and I'm going to ignore this minor issue with the Anniversary addition, and chock  it up as a MS or a HP Image result for Bugs I appreciate everyone that tried their best to help me on this issue. It's time to let it rest for now. We gave it our best shot and I learned some things along the way!;) A little over board, but I like to have a little fun on my replies some times. I'm just a old country boy that loves people! Been around awhile and hoping I'll be around awhile longer!:ph34r:

Capture25.JPG

Share this post


Link to post
Share on other sites

Hi There! If this is the only bug I find in the anniversary addition, I'll be a very happy camper.:D

Have you found any bugs in anniversary that you would like to share here on the forum? I would like to hear about them. I'm going to start a thread hear that you can reply on!;)

Share this post


Link to post
Share on other sites

I too am having this problem. I've been avoiding it for many  months. I felt compelled to let you know that I don't have any HP products, yet I still get the problem. Thus, it's less likely an HP bug, and more likely MS bug. I tried just about everything on this thread with pretty much the same results. Occasionally, Devices and Printers loads normally, but most of the time it takes about 3 or 4 minutes to load. I use all Canon printers, with the exception of a Dell Laser Color Printer (wifi). All of which work at the moment. I did have a bunch of scanner problems, but those went away at some point (I think I updated the drivers If i recall).  Anyway, I hope someone figures this out. it's pretty much my only complaint about windows 10. 

Share this post


Link to post
Share on other sites

I have been struggling with this same darn issue and finally found the fix. Follow this link

Fix for D&P slow to load

MarkT94 Jan 16, 2017 at 8:39 AM 
 

I have seen this a few times.  Open Explorer.  Left-click on File, then select "Change Folder and Search Options.  On the General tab, change the pull down for Open File Explorer from "Quick Access" to "This PC".  That should take care of it.  It's a known issue, but can't remember where the link was.

Share this post


Link to post
Share on other sites

I guess that you guys didn't hear.  The time delay in the Devices and Printers is Microsoft's "Coffee Bar".  You use that as an excuse to get another cup of coffee....then drink it....rinse out your cup...run to the restroom...then come back and close the window with a frustrated grunt.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Who's Online   0 Members, 0 Anonymous, 23 Guests (See full list)

    There are no registered users currently online