• Welcome to Windows10Forum.com, a free community where people just like you come together to discuss, share and learn how to use their computers. Using this forum is easy and fun. As a guest, you can browse and view all the content on the site, however, you won't be able to leave comments or create new topics unless you create a free account. 

    Click here to Register a free account now and JOIN the discussion!

holdum333

Devices and Printers Menu takes forever to load

Recommended Posts

HI Just like the title says. Devices and printers take forever to load after the anniversary update. That's the only problem that I haven't solved with the update!

Wondering if anyone is having this problem or has a solution to this problem! Every thing else seems to be running OK!

Thanks!

Share this post


Link to post
Share on other sites

I experienced the same problem after Anniversary Update.

Looked in Services and discovered both Bluetooth entries are set to manual.

Started both Bluetooth entries then Right clicked on Properties and set both to Automatic.

Now my Devices and Printers load pretty quickly.

Mick.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi @ACE That did it friend! Don't know what Bluetooth had to do with it, but I disabled the Bluetooth entries and Devices and Printers load normal again. I don't have any Bluetooth devices that I know of! Nice find Mick!

Thanks Mick. Wonder if MS will put out a patch and fix that??;)

Share this post


Link to post
Share on other sites

Hi! The problem is back and I have Bluetooth disabled?? Go figure! Takes forever to open!!>:( Worked good for awhile. I had to restore my PC back with Macrium. After trying the chkdsk /r /f. My PC bricked! Have no clue why. All is back up and running. Thanks to MCT flash and Macrium Reflect, I'm back up and going strong! Hard to keep me down!;)

Capture28.JPG

Share this post


Link to post
Share on other sites

Are you saying Windows takes forever to open? Are you using Win Patrol to monitor what is in startup or msconfig?

Take a look. Another thing that causes slow boot is devices looked for that are not there i.e. floppy drive or too many devices listed for boot order.

I have been going back to setting boot priority on slow moving system to hard drive # 1 and dvd drive # 2 with all other possibilities disabled.

Share this post


Link to post
Share on other sites

Hi @Rich-M Windows boots just fine. The only problem I'm having is what the thread is saying! Devices and printers take forever to load after the anniversary update. I'm thinking it's a MS bug and it will be patched soon!

Every thing else is working just fine at the moment. My boot order is just fine and the only thing I have on start-up is Windows Defender and MBAM. I'm a simple man with a simple plan. I only have 1 drive and 1 OS!;)

  • Upvote 1

Share this post


Link to post
Share on other sites

OK I can read that so you are saying that  "Devices and Printers"  is slow to open, but your printers work normally?

I have seen that before and it is annoying but it isn't that printers a long time to print its simply the Devices and Printers Appellat opens slowly, I got it now!

Sometimes it takes these old brains more time to reach conclusion is all!

Share this post


Link to post
Share on other sites

Hi! I have disabled both Bluetooth entries in services. I have uninstalled my HP printer and reinstalled it twice. Some times it opens just fine, but most of the time it takes 3+ minutes to open. I have to set and watch the bar crawl across the top. Not a big deal. It's just aggravating. I'm sure MS will fix this problem soon. I have seen several users complaining about this problem. The printer scans and prints just fine.

Here's a handy tool I use all the time to get my HP printer up and going! It works great and I have used it on my printer and a couple of seniors printers!

http://support.hp.com/us-en/document/c02073861?jumpid=ex_r4155/hho/ipg/ccdoc/trailhead_doc

Share this post


Link to post
Share on other sites

I just used HP link above to install the latest driver and It is now opening just fine. Computers were made to keep us all upset and talking to ourselves.

I have updated the driver before and nothing. This time it seems to be working like it's supposed to. So I'm a happy camper for now. We'll see how long that lasts!xD

Edited by holdum333

Share this post


Link to post
Share on other sites

Yeah why doing the same thing that didn't work in the past  and suddenly does work now causes the frustration that keeps us going

Share this post


Link to post
Share on other sites

Hi! Here's a update on this issue. I reinstalled my HP printer and updated the latest driver. Then I made it my default printer. This is the second day that it has opened like it should. I really believe the issue has been solved; but if it re- accrues, I will report back here!;)

Share this post


Link to post
Share on other sites

Hi! Worked great for two days. Now it's back taking 3+ minutes to load. I give up! >:( It seems to be a common problem with anniversary , so maybe MS will pull their head out and put out a patch. Makes no sense to work for a couple of days and then stop!

There is nothing wrong with my printer. There's a bug in File Explorer! Fix it MS!

Capture25.JPG

Edited by holdum333

Share this post


Link to post
Share on other sites

Has Windows 10 removed your good driver and installed a generic driver.

Check your latest installed updates for a printer driver update since you installed the good driver..

Share this post


Link to post
Share on other sites

Heya @ACE I did a bunch of cleaning and installed updates history got deleted. That very well might be happening. I went to HP and got the driver for my printer and installed it. Devices and Printer is working again, but I've been there before.;) I have the HP driver on my desktop so I can install it again if needed.

Thanks for your help. You are appreciated! Here's my update history! I don't like losing and I'm going to keep trying to solve this for awhile longer before giving up. It sure seems to be related to a driver. I wish MS would leave my damn drivers alone!>:(

Capture25.JPG

Edited by holdum333

Share this post


Link to post
Share on other sites

Looks like Microsoft updates keep knocking your good Driver from HP out.

It has happened to me before with a Graphics Driver.

Share this post


Link to post
Share on other sites

Heya! @ACE I believe you maybe right friend!. I have the good HP driver  on my desktop now. I'll keep following this issue and report back my findings!

Why doesn't MS leave the drivers alone. it seems they don't know what the hell they are doing!

PS Still opening like it's supposed at the moment!;) I will try to catch the next MS update. It should show up in the Reliability Monitor if it updates any drivers. I have seen where MS has updated some drivers before. I watch the RM closely. It can be a big help some times, even though there is a lot of things that aren't important. Much like the Event Viewer.:D

Edited by holdum333

Share this post


Link to post
Share on other sites

Heya @ACE Here's what I installed for my HP printer. I'm not the best when it comes to updating drivers, but I'm thinking I got this right.;)

Anyone have a comment; it would be appreciated! I'm thinking this printer is 4 or 5 years old!

Capture25.JPG

Share this post


Link to post
Share on other sites

It sure looks like MS is replacing your manufacturers driver with a crappy windows one, and it will continue to do so unless you turn driver updates off. Have a read of this HERE.

Share this post


Link to post
Share on other sites

Heya @gus Thanks for your help. We have been through this before. I get so far with your link, but I can't get to the driver part.

I can get as far as  my first screen shot shows, but not to where it drops down and you uncheck the driver option, There is no drop down in my system like it shows in your link. I hope I'm making this clear. I really appreciate your help my friend. I just can't get there on my system.;) The first screen shot is from your link. The second screen shot is from my system, which does not have the drop down shown in the link you posted! I can't get to the 4 options shown in the link and check the driver option.

 

Capture25.JPG

Capture26.JPG

Share this post


Link to post
Share on other sites

I am thinking the same,Gus.

Why M$ thought they could do a better job of installing Drivers than us amazes me.

They should have stayed the hell away from Drivers.

Mick.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Who's Online   0 Members, 0 Anonymous, 10 Guests (See full list)

    There are no registered users currently online