• Welcome to Windows10Forum.com, a free community where people just like you come together to discuss, share and learn how to use their computers. Using this forum is easy and fun. As a guest, you can browse and view all the content on the site, however, you won't be able to leave comments or create new topics unless you create a free account. 

    Click here to Register a free account now and JOIN the discussion!

friyatnaesa

My Windows 10 laptop lags when on battery power

Recommended Posts

These details may be useful, I’ll try to specify every little detail about the issue that I can remember:

  • Summary of my laptop’s specs: ASUS TUF FX505GE, i7–8750, GTX 1050Ti 4GB, 8GB RAM, SSD+HDD, Windows 10 Home Edition SL
  • The laptop is still relatively new, just bought around 1 month ago but the issue started since around last week. At first, there was no issue at all.
  • The lagging issue occurred whenever I unplugged my laptop from the charger, 1–2 seconds after Windows automatically switch the power plan to Power Saver mode. Suddenly, the cursor apparently disappears. When I tried to move the the mouse/trackpad to get the cursor to the bottom of the screen to show the taskbar (I hide the taskbar), I notice from the taskbar opening animation that the OS is lagging very, very bad. I also confirmed that it is lagging when I hit the Windows button and saw that the start menu opens up very slow and jagged.
  • Related to the above, I’ve tried to fiddle with the Power Saver plan and the overall power management settings in Windows to no avail. Also have tried to reset the power plan settings to default.
  • Still related to the above, I tried to stop Windows from switching automatically to Power Saver plan when unplugging the charger but I can’t find any helpful article in the internet.
  • Plugging the laptop in to the power socket after the lagging appears does not solve the issue.
  • When it is lagging, the only thing I could do is to fire up Ctrl+Alt+Del and restart, with the charger plugged in since booting up.
  • During the Ctrl+Alt+Del screen (I don’t know the proper name for it, it’s the menu that is displayed after you hit the three keys that shows the option of Task Manager, restart, shut down, etc), I noticed that the cursor is there and I can move it smoothly without any lagging issues
  • If I log out, the lagging issue is gone in the login screen. However, after signing in to my account again, the lagging issue comes back even after I plugged the laptop in.
  • I have all the latest updates from the Windows Update, and also made sure that all the drivers are up-to-date.
  • While researching for this issue, I found that the laptop battery status says “plugged in, not charging”. I managed to solve this issue after searching through the web but the main lagging issue still persists.
  • Because I very rarely travel with my laptop, most of the time I left the laptop at my desk. However, I always plugged it in to the power socket even when the battery is already full (looks like this is the cause of the “plugged in, not charging” issue above).
  • I have also uninstalled the Windows-related softwares that came with the laptop from ASUS, but still have the issue.
  • I haven’t ruled out the possibility of any hardware-related cause because I haven’t tried the reset Windows option, but somehow all things are pointing out to software/OS-related issue.

This issue seems to be very specific and I couldn’t find any topic about this issue in the internet. It’s very annoying when I have to use my laptop while traveling.

Any help or insight is very much appreciated. Thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By ACHARKI YAssir
      Hi, my windows (Windows 10 x64 Enterprise) keep crashing in boot, i get the following error :
      Error : 0xc0000225 (File: \Boot\BCD).

      Can you help me please, i got this URL from Boot-Repair-Disk.
       
      http://paste.ubuntu.com/p/fWzX6B2Wnp/
      thanks in advance.
    • By newu
      Hi,

      I have Windows 10 Pro on a new desktop.  I have created before an image of Windows 7 system on my older PC. 
      I was wondering if I create a virtual drive in Windows 10 (on Hard Disk), whether it's possible
      to restore the Windows 7 image on the virtual drive ??

    • By R_Paradise
      I updated my windows 7 to windows 10, I've had installed adobe CS5 on my computer a few years ago and it always worked great but since my upgrade to windows 10 when I try to open any of Adobe CS5 I get a message and error 213:11 and that's it I can't run any of them. I've noticed when I open all apps Adobe CS5 is no longer there. Does anyone have any info on this problem? I would greatly appreciate a solution. Thanks
    • By crazylittl3liza
      I have an HP Pavilion p390nr which I bought for 2 very lame reasons the touchscreen being 1 of them. Sadly since the roll out of the creators update last year my touchscreen stopped working, it still showed in the device manager however hidden it was there but after various attempts with Microsoft on the line or trying the other options of fix its others were doing the drivers flat disappeared and now when you go to Control Panel\System and Security\System it says no pen and touch available for this display. I literally have no clue which way to go on this mess oh ya and in all the "fix it's" I've lost my Microsoft account 'live' attached to my one drive that I had every photo & over 20,000 songs my kids entire 20yrs my deceased horse no joke everything backed up to GONE no way to retrieve. failed factory reset everything tried messes this laptop up more pretty soon I'm going to own very expensive & ugly paper weight???
      Please the media created a purchase is worthless as apparently this laptop has to have its BIOS adjusted to use media from cd or something stupid I don't know it's not like any of the companies come with owners manuals apparently when your laptop goes down you're expected to have another one so you can hop online and look up what to do! I'm sorry I cry and get angry every time I have to try to figure this out because I had just scanned all the photos of my deceased mother for safe keeping and was so glad I did as I live in the area of the Thomas fires she was killed when I was 4 that was 40yrs ago and now I have NOTHING of her if there is anyway to retrieve my pc and my photos please I would forever be in your debt
    • By Vern11
      All of a sudden, when I try to view any or all disk drives by double-clicking their icons on the desktop, NONE of them will open or display. What I always get instead is the error message: "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item."

      I get the same error when I try to run any *.msc or control panel. When I choose Settings instead of Control Panel, nothing happens at all. I get it even if I simply double-click "This Computer"!

      I'm running 64-bit Windows 10 Pro 1803, and since there are no other users, my user account is an administrator account. Which means this almost certainly isn't actually a permission problem at all. Even if it was, since I cannot open any disk drive, I can't examine or change the owner/permissions.

      When I looked up what might be causing this error, none of the alleged "explanations" fit what I'm seeing. Here's what Microsoft has to say about this error...

      1: Check the permission of the file or folder: I can't! At least not in Explorer.

      2: Check the file location: There can be no doubt as to where my disk drives are!

      3: Make sure that the file has not been moved or deleted: I know with certainty that my disk drives are right where they've always been.

      4: Recreate the shortcut to check for corruption: These are not shortcuts.

      5: Unblock the file: My disk drives are not "blocked".

      6: Check to see if your antivirus software is blocking the file: Due to an unrelated issue (some process was deleting a few Nirsoft.net executable files whenever I extracted then from a zip file - I have now solved that), I have uninstalled all anti-malware tools on the computer in question. In fact, the very reason I booted up was to re-install them, which I obviously cannot do when Explorer can't find any of my disk drives! In any case, I ran the latest MBAM and found no malware.

      For the heck of it, I ran SFC, and it didn't find any problems.

      What's going on? What can I do?

      Thanks!
  • Who's Online   0 Members, 0 Anonymous, 14 Guests (See full list)

    There are no registered users currently online