Sean Landrum

Member
  • Content Count

    1
  • Joined

  • Last visited

Everything posted by Sean Landrum

  1. Dear helpful people,Over the last few weeks I eagerly put together my new PC. Progressed through the windows 10 installation smoothly, and proceeded to install drivers for all of my hardware and periferals. During the process my screen went black, and I assumed it to be resetting after installing a video driver, as they do when shifting resolutions. So I left it two hours, and when I returned, it was the same. So I pressed the power button to initiate shut down, which went smoothly. Then restarted, which progressed passed POST, motherboard manufacturer's image loading screen, and then into the black void from whence it was moments before. Ok. Through the last two days I have tested rigorously to discover a cause, and searched fruitlessly for a solution that would work for me. The issue arrives the moment I install a display driver, regardless of if it is a display driver for my onboard graphics, or my gpu. It happens regardless if I use my motherboard's disk, drivers downloaded from manufactuerer websites, or through the windows update utility. It is an easily repeatable occurance.My system specifications are as follows.Windows 10 home editionMPB Z390 Gaming Pro Carbon MotherboardIntel i7 9700k32gb Corsair Vengence ramNvidia RTX 2080ti with EK water block Samsung 860 EVO V-NAND M.2 1TB SSD 2Tb Barracuda HDD Asus PB287Q 28" MonitorSo far I have tried:Installing drive through DDU Installing on m.2 SSDInstalling on 3.5" HDInstalling on HDs in RAID Windows key + P fixInstalling graphics drivers from the internet, CD and Windows update utilityCable checks,Alternate Display Ports on both GPU and MotherboardThe system runs stably without installing a display driver. I am posting this message from chrome installed on it. But obviously, to use as a gaming rig, no display driver is kind of a killer.Thank you for your time and advice in advance, I am struggling to understand what I can do.